PHP 7.4 Abschaltung
CMS-Systeme /Blogs Shopsoftware

IONOS und STRATO schalten PHP 7.4 und frühere Versionen ab

25. Januar 2023

Nach HostEurope haben nun auch STRATO und IONOS / 1&1 angekündigt, sehr zeitnah PHP 7.4 und frühere Versionen abzuschalten. Shopbetreiber und Webseitenbetreiber müssen nun schnell reagieren. Wir schreiben hier kurz, was zu tun ist.

Welche Folgen hat das für Sie?

Prüfen Sie als erstes, ob Ihre Anwendungen unter PHP 8 noch laufen. Gerne helfen wir Ihnen dabei. In der Regel benötigen Sie eine aktuelle Version dazu.

Es wird erhebliche Probleme geben, wenn Sie eine Anwendung unter PHP 8 betreiben wollen, die aber nicht PHP8-kompatibel ist. Egal ob Sie nun Joomla!, WordPress, Shopware 5, PrestaShop, xt:Commerce oder modified eCommerce nutzen. Ist die Anwendung nicht kompatibel, wird sie sofort einen Fehler anzeigen und nicht mehr erreichbar sein.

Wenn Sie sich unsicher sind, ob Ihr System bereits PHP 8 kompatibel ist, können Sie uns gerne kontaktieren, damit wir uns einmal einen genaueren Überblick verschaffen.

Wenn Ihr System nicht unter PHP 8 läuft?

Vielleicht haben Sie die PHP-Version Ihrer Installation testweise schon einmal auf PHP 8 umgestellt und festgestellt, dass nur noch eine weiße Seite zu sehen ist. Das lässt recht schnell darauf schließen, dass Ihr System noch nicht bereit ist für den PHP-Wechsel.

Die Ursachen hier für können vielfältig sein. Gerade bei Systemen wie WordPress, sorgen oftmals kleinere Plugins und Erweiterungen für Probleme, denn auch diese müssen mit der eingesetzten PHP-Version kompatibel sein. Bei Shopware und anderen Shopsystemen wird es komplexer.

Was können Sie jetzt sofort tun?

Im Kern müssen Sie Ihre Installation inklusive aller Erweiterungen und Module einmal updaten. Informieren Sie sich im Vorhinein, ab welcher Version Ihrer Systeme eine PHP-Kompatibilität gegeben ist und updaten Sie mindestens bis auf diese.

Je nach System kann dieser Prozess einfacher oder komplexer ausfallen, in jedem Fall jedoch sollten Sie vorher unbedingt ein Backup Ihrer Dateien und Datenbanken machen.

Wenn Sie Hilfe beim Updaten Ihrer Installation brauchen, helfen wir Ihnen natürlich gerne. Kontaktieren Sie uns einfach über unser Kontaktformular, per E-Mail oder telefonisch über unsere kostenlose Service-Hotline.

Schlagwortemodified eCommerceShopsystemShopwareUpdatext:Commerce

Über Immo W. Fietz

Immo W. Fietz, Jahrgang 1970, ist gelernter Programmierer, studierter Jurist und Betriebswirt sowie Sachverständiger für Neue Medien. Hier schreibt er als leidenschaftlicher eCommerce-Spezialist der ersten Stunde über tägliche Probleme im Online-Handel und der Verknüpfung von stationärem Handel mit dem Internet, lokale Marktplätze, Stadtentwicklung in der Digitalisierung und politische Rahmenbedingungen des eCommerce.

Du hast eine Frage?

Gerne steht Dir unser Experte mit Rat und Tat zur Seite und beantwortet Deine Frage zu diesem, aber auch zu allen anderen Themen rund um modified eCommerce, Shopsystem oder Update.

* Pflichtangaben Bitte beachte unsere Datenschutzrichtlinien.
Immo W. Fietz
Immo W. Fietz eCommerce Berater seit 25 Jahren
0 51 41. 204 89 20

Nichts mehr verpassen - mit unserem Newsletter

Bitte beachte unsere Datenschutzrichtlinien.
Nächster Artikel

von Immo W. Fietz

Karte mit Standort von FIETZ eCommerce
Telefon-Support:
0800 250 40 50